<!-- =========================
     Page Breadcrumb   
============================== -->
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars, Career</title>
	<link rel="canonical" href="https://www.thesuperficial.com/armie-hammer-net-worth/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars, Career" />
	<meta property="og:description" content="Armand Douglas Hammer or more popular as Armie Hammer isn&#8217;t an unknown face on the television scene and in Hollywood. He is an American actor who is best recognized for his role as Wiklevoss twins in the 2010 movie &#8220;The Social Network&#8221;. People also recognize Armie for his charming looks and incredible on-screen presence. For [&hellip;]" />
	<meta property="og:url" content="https://www.thesuperficial.com/armie-hammer-net-worth/" />
	<meta property="og:site_name" content="The Superficial" />
	<meta property="article:published_time" content="2022-03-24T12:03:46+00:00" />
	<meta property="article:modified_time" content="2022-03-24T12:03:47+00:00" />
	<meta property="og:image" content="https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31.png" />
	<meta property="og:image:width" content="781" />
	<meta property="og:image:height" content="519" />
	<meta property="og:image:type" content="image/png" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Elena Jones" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="11 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.thesuperficial.com/#website","url":"https://www.thesuperficial.com/","name":"The Superficial","description":"","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.thesuperficial.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#primaryimage","inLanguage":"en-US","url":"https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31.png","contentUrl":"https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31.png","width":781,"height":519,"caption":"Armie Hammer Net Worth"},{"@type":["WebPage","FAQPage"],"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#webpage","url":"https://www.thesuperficial.com/armie-hammer-net-worth/","name":"Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars, Career","isPartOf":{"@id":"https://www.thesuperficial.com/#website"},"primaryImageOfPage":{"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#primaryimage"},"datePublished":"2022-03-24T12:03:46+00:00","dateModified":"2022-03-24T12:03:47+00:00","author":{"@id":"https://www.thesuperficial.com/#/schema/person/0e6816858f22f4cee943bb3fb1bc3202"},"breadcrumb":{"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#breadcrumb"},"mainEntity":[{"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648033513751"},{"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648033600468"},{"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648034537343"},{"@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648034777757"}],"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.thesuperficial.com/armie-hammer-net-worth/"]}]},{"@type":"BreadcrumbList","@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.thesuperficial.com/"},{"@type":"ListItem","position":2,"name":"Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars"}]},{"@type":"Person","@id":"https://www.thesuperficial.com/#/schema/person/0e6816858f22f4cee943bb3fb1bc3202","name":"Elena Jones","image":{"@type":"ImageObject","@id":"https://www.thesuperficial.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7bca2668fca349a15c503dfc9d1b0bff?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/7bca2668fca349a15c503dfc9d1b0bff?s=96&d=mm&r=g","caption":"Elena Jones"},"url":"https://www.thesuperficial.com/author/elena/"},{"@type":"Question","@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648033513751","position":1,"url":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648033513751","name":"How old is Armie Hammer?","answerCount":1,"acceptedAnswer":{"@type":"Answer","text":"Hammer was born on August 28, 1986. this makes him 35 years old as of 2022.  ","inLanguage":"en-US"},"inLanguage":"en-US"},{"@type":"Question","@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648033600468","position":2,"url":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648033600468","name":"How much is Armie Hammer worth?","answerCount":1,"acceptedAnswer":{"@type":"Answer","text":"Armie Hammer net worth is around $10 to $16 million at present. He has earned all of his wealth from more than 10 years of a successful career built on different types of movies, voice acting, and television sitcoms. ","inLanguage":"en-US"},"inLanguage":"en-US"},{"@type":"Question","@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648034537343","position":3,"url":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648034537343","name":"Michael Armand Hammer net worth?","answerCount":1,"acceptedAnswer":{"@type":"Answer","text":"Michael Armand Hammer is Armie's father who owns several businesses of his own. In addition to that, he has also inherited the estates of his grandfather, Armand Hammer. Including all his wealth, businesses, and estates, Michael has an estimated net worth of $180 million as per a few sources online. ","inLanguage":"en-US"},"inLanguage":"en-US"},{"@type":"Question","@id":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648034777757","position":4,"url":"https://www.thesuperficial.com/armie-hammer-net-worth/#faq-question-1648034777757","name":"How tall is Armie Hammer?","answerCount":1,"acceptedAnswer":{"@type":"Answer","text":"Armie has a charming on-screen appearance with a well-built body and has a height of 1.96\u00a0m/ 6 feet inches. ","inLanguage":"en-US"},"inLanguage":"en-US"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Superficial &raquo; Feed" href="https://www.thesuperficial.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Superficial &raquo; Comments Feed" href="https://www.thesuperficial.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Superficial &raquo; Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars Comments Feed" href="https://www.thesuperficial.com/armie-hammer-net-worth/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thesuperficial.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.thesuperficial.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='toc-screen-css'  href='https://www.thesuperficial.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=2106' type='text/css' media='all' />
<link rel='stylesheet' id='newsup-fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C500%2C700%2C800%7CWork%2BSans%3A300%2C400%2C500%2C600%2C700%2C800%2C900%26display%3Dswap&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.thesuperficial.com/wp-content/themes/newsup/css/bootstrap.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='newsup-style-css'  href='https://www.thesuperficial.com/wp-content/themes/news-way/style.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.thesuperficial.com/wp-content/themes/newsup/css/all.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css'  href='https://www.thesuperficial.com/wp-content/themes/newsup/css/owl.carousel.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='smartmenus-css'  href='https://www.thesuperficial.com/wp-content/themes/newsup/css/jquery.smartmenus.bootstrap.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.thesuperficial.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14' type='text/css' media='all' />
<link rel='stylesheet' id='newsup-style-parent-css'  href='https://www.thesuperficial.com/wp-content/themes/newsup/style.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='newsway-style-css'  href='https://www.thesuperficial.com/wp-content/themes/news-way/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='newsway-default-css-css'  href='https://www.thesuperficial.com/wp-content/themes/news-way/css/colors/default.css?ver=5.9.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.thesuperficial.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/navigation.js?ver=5.9.2' id='newsup-navigation-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/bootstrap.js?ver=5.9.2' id='bootstrap-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/owl.carousel.min.js?ver=5.9.2' id='owl-carousel-min-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/jquery.smartmenus.js?ver=5.9.2' id='smartmenus-js-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/jquery.smartmenus.bootstrap.js?ver=5.9.2' id='bootstrap-smartmenus-js-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/jquery.marquee.js?ver=5.9.2' id='newsup-marquee-js-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/main.js?ver=5.9.2' id='newsup-main-js-js'></script>
<link rel="https://api.w.org/" href="https://www.thesuperficial.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.thesuperficial.com/wp-json/wp/v2/posts/9110" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thesuperficial.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thesuperficial.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.2" />
<link rel='shortlink' href='https://www.thesuperficial.com/?p=9110' />
<link rel="alternate" type="application/json+oembed" href="https://www.thesuperficial.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thesuperficial.com%2Farmie-hammer-net-worth%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thesuperficial.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thesuperficial.com%2Farmie-hammer-net-worth%2F&#038;format=xml" />
<link rel="pingback" href="https://www.thesuperficial.com/xmlrpc.php"><style type="text/css" id="custom-background-css">
    .wrapper { background-color: #eee; }
</style>
    <style type="text/css">
            body .site-title a,
        body .site-description {
            color: ##fff;
        }

        .site-branding-text .site-title a {
                font-size: px;
            }

            @media only screen and (max-width: 640px) {
                .site-branding-text .site-title a {
                    font-size: 40px;

                }
            }

            @media only screen and (max-width: 375px) {
                .site-branding-text .site-title a {
                    font-size: 32px;

                }
            }

        </style>
    </head>
<body class="post-template-default single single-post postid-9110 single-format-standard wp-embed-responsive  ta-hide-date-author-in-list" >
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">
Skip to content</a>
    <div class="wrapper">
        <header class="mg-headwidget center light">
            <!--==================== TOP BAR ====================-->

            <div class="clearfix"></div>
                        <div class="mg-nav-widget-area-back" style='background-image: url("" );'>
                        <div class="overlay">
              <div class="inner"  style="background-color:#fff;" > 
                <div class="container-fluid">
    <div class="mg-nav-widget-area">
        <div class="row align-items-center">
                        <div class="col-md-4 col-sm-4 text-center-xs">
                            <div class="heacent">Thu. Mar 24th, 2022                         <span  id="time" class="time"></span>
                                      </div>
              
            </div>

            <div class="col-md-4 col-sm-4 text-center-xs">
                <div class="navbar-header">
                                          <div class="site-branding-text">
                        <h1 class="site-title"> <a href="https://www.thesuperficial.com/" rel="home">The Superficial</a></h1>
                        <p class="site-description"></p>
                    </div>
                                  </div>
            </div>


                         <div class="col-md-4 col-sm-4 text-center-xs">
                <ul class="mg-social info-right heacent">
                    
                                      </ul>
            </div>
                    </div>
    </div>
</div>
              </div>
              </div>
          </div>
    <div class="mg-menu-full">
      <nav class="navbar navbar-expand-lg navbar-wp">
        <div class="container-fluid">
          <!-- Right nav -->
                    <div class="m-header align-items-center">
                                                <a class="mobilehomebtn" href="https://www.thesuperficial.com"><span class="fas fa-home"></span></a>
                        <!-- navbar-toggle -->
                        <button class="navbar-toggler mx-auto" type="button" data-toggle="collapse" data-target="#navbar-wp" aria-controls="navbarSupportedContent" aria-expanded="false" aria-label="Toggle navigation">
                          <i class="fas fa-bars"></i>
                        </button>
                        <!-- /navbar-toggle -->
                        <div class="dropdown show mg-search-box pr-2 d-none">
                            <a class="dropdown-toggle msearch ml-auto" href="#" role="button" id="dropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                               <i class="fas fa-search"></i>
                            </a>

                            <div class="dropdown-menu searchinner" aria-labelledby="dropdownMenuLink">
                        <form role="search" method="get" id="searchform" action="https://www.thesuperficial.com/">
  <div class="input-group">
    <input type="search" class="form-control" placeholder="Search" value="" name="s" />
    <span class="input-group-btn btn-default">
    <button type="submit" class="btn"> <i class="fas fa-search"></i> </button>
    </span> </div>
</form>                      </div>
                        </div>
                        
                    </div>
                    <!-- /Right nav -->
         
          
                  <div class="collapse navbar-collapse" id="navbar-wp">
                  	<div class="d-md-block">
                  <ul class="nav navbar-nav mr-auto"><li class="nav-item menu-item "><a class="nav-link " href="https://www.thesuperficial.com/" title="Home">Home</a></li></ul>
        				</div>		
              		</div>
                  <!-- Right nav -->
                    <div class="desk-header pl-3 ml-auto my-2 my-lg-0 position-relative align-items-center">
                        <!-- /navbar-toggle -->
                        <div class="dropdown show mg-search-box">
                      <a class="dropdown-toggle msearch ml-auto" href="#" role="button" id="dropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                       <i class="fas fa-search"></i>
                      </a>
                      <div class="dropdown-menu searchinner" aria-labelledby="dropdownMenuLink">
                        <form role="search" method="get" id="searchform" action="https://www.thesuperficial.com/">
  <div class="input-group">
    <input type="search" class="form-control" placeholder="Search" value="" name="s" />
    <span class="input-group-btn btn-default">
    <button type="submit" class="btn"> <i class="fas fa-search"></i> </button>
    </span> </div>
</form>                      </div>
                    </div>
                    </div>
                    <!-- /Right nav --> 
          </div>
      </nav> <!-- /Navigation -->
    </div>
</header>
<div class="clearfix"></div>
 <!--==================== Newsup breadcrumb section ====================-->
<!-- =========================
     Page Content Section      
============================== -->
<main id="content">
    <!--container-->
    <div class="container-fluid">
      <!--row-->
      <div class="row">
        <!--col-md-->
                                                <div class="col-md-9">
                    		                  <div class="mg-blog-post-box"> 
              <div class="mg-header">
                                <h1 class="title single"> <a title="Permalink to: Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars">
                  Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars</a>
                </h1>

                <div class="media mg-info-author-block"> 
                                    <div class="media-body">
                                                            <span class="mg-blog-date"><i class="fas fa-clock"></i> 
                      Mar 24, 2022</span>
                                      </div>
                </div>
              </div>
              <img width="781" height="519" src="https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31.png" class="img-fluid wp-post-image" alt="Armie Hammer Net Worth" srcset="https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31.png 781w, https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31-300x199.png 300w, https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31-768x510.png 768w" sizes="(max-width: 781px) 100vw, 781px" />              <article class="small single">
                
<p>Armand Douglas Hammer or more popular as Armie Hammer isn&#8217;t an unknown face on the television scene and in Hollywood. He is an American actor who is best recognized for his role as Wiklevoss twins in the 2010 movie &#8220;The Social Network&#8221;. People also recognize Armie for his charming looks and incredible on-screen presence. For those who are curious about how much is Armie Hammer worth, this article is might interest you.  It covers the actor&#8217;s financial background, his professional details, and much more that you probably didn&#8217;t know about him. But for now, <strong>Armie Hammer net worth is between $10 to $16 million</strong>. </p>



<p>Hammer has been in the film industry for over a decade now, and he has amassed this fortune through his acting career. He has been a part of several award-winning films and shows like &#8220;The Lone Ranger&#8221;, the popular sitcom, &#8220;Arrested Development&#8221;, &#8220;Call Me by Your Name&#8221;, among many others. Aside from his identity as an actor in Hollywood, Armie also has a pretty solid family background that he is known for. He is the great-grandson of the oil magnate Armand Hammer and the legendary Russian singer/ actress Olga Vadimovna Vadina. Armie, therefore,&nbsp;has grown up amidst wealth and luxury. </p>



<p>That said, let&#8217;s dig deeper into Armie Hammer net worth, Armie Hammer family wealth,  Michael Armand Hammer net worth, his family history, assets, and more. </p>



<h2><span id="Armie_Hammer_Net_Worth_Biography_and_Early_Life_Michael_Armand_Hammer_Net_Worth_Career_Assets_and_Personal_Life">Armie Hammer Net Worth, Biography and Early Life, Michael Armand Hammer Net Worth, Career, Assets, and Personal Life</span></h2><div id="toc_container" class="no_bullets"><p class="toc_title">Contents</p><ul class="toc_list"><li><a href="#Armie_Hammer_Net_Worth_Biography_and_Early_Life_Michael_Armand_Hammer_Net_Worth_Career_Assets_and_Personal_Life"><span class="toc_number toc_depth_1">1</span> Armie Hammer Net Worth, Biography and Early Life, Michael Armand Hammer Net Worth, Career, Assets, and Personal Life</a><ul><li><a href="#Armie_Hammer_Net_Worth_and_Salary"><span class="toc_number toc_depth_2">1.1</span> Armie Hammer Net Worth and Salary</a></li><li><a href="#Biography_and_Early_Life"><span class="toc_number toc_depth_2">1.2</span> Biography and Early Life  </a><ul><li><a href="#Michael_Armand_Hammer_Net_Worth"><span class="toc_number toc_depth_3">1.2.1</span> Michael Armand Hammer Net Worth</a></li></ul></li><li><a href="#Career"><span class="toc_number toc_depth_2">1.3</span> Career</a><ul><li><a href="#Career_since_2017_Adding_to_Armie_Hammer_Net_Worth"><span class="toc_number toc_depth_3">1.3.1</span> Career since 2017 Adding to Armie Hammer Net Worth</a></li><li><a href="#Other_Ventures_Leading_up_to_Armie_Hammer_Net_Worth"><span class="toc_number toc_depth_3">1.3.2</span> Other Ventures Leading up to Armie Hammer Net Worth</a></li></ul></li><li><a href="#Awards_and_Achievements"><span class="toc_number toc_depth_2">1.4</span> Awards and Achievements</a></li><li><a href="#Personal_Life_and_Assets"><span class="toc_number toc_depth_2">1.5</span> Personal Life and Assets</a></li><li><a href="#Wrapping_Up"><span class="toc_number toc_depth_2">1.6</span> Wrapping Up</a></li></ul></li><li><a href="#Frequently_asked_Questions_FAQs"><span class="toc_number toc_depth_1">2</span> Frequently asked Questions (FAQs)</a></li></ul></div>




<p>&#8220;The Social Network&#8221; actor made his debut in Hollywood with the movie &#8220;Flicka&#8221; and has been a part of innumerable movies and television shows since then. Armie Hammer net worth is recently evaluated to be between $10 to $16 million. He has collected all of this wealth from his acting career and reportedly claims no inheritance of wealth from his ancestral property. </p>



<h3><span id="Armie_Hammer_Net_Worth_and_Salary">Armie Hammer Net Worth and Salary</span></h3>



<p>While there is no fixed salary for this Hollywood actor, he has made good earnings from the films he has worked in. The films&#8217; box office success and collection play a big role to play in how big a paycheck he gets. Starting with his most prominent film, &#8220;The Social Network&#8221; (2010), made a worldwide box office collection of $224.92 million in addition to winning more than 170 awards. Needless to say, this movie&#8217;s success had made a significant upturn to Armie Hammer Net Worth. </p>



<div class="wp-block-image"><figure class="aligncenter size-full is-resized"><img loading="lazy" src="https://www.thesuperficial.com/wp-content/uploads/2022/03/2-29.png" alt="The Social Network grossed $224.92 million at the box office upturning Armie Hammer Net Worth" class="wp-image-9537" width="730" height="402" srcset="https://www.thesuperficial.com/wp-content/uploads/2022/03/2-29.png 630w, https://www.thesuperficial.com/wp-content/uploads/2022/03/2-29-300x165.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></figure></div>



<p>Some other high-grossing movies that helped Hammer pull in a ransom amount to add to his bank are- &#8220;J. Edgar&#8221; (2011) which grossed $84.6 million, &#8220;Mirror Mirror&#8221; (2012) with more than $183 million. Further, his movies &#8220;The Lone Ranger&#8221; made a box office earnings of $260.5 million, two movies &#8220;The Man From U.N.C.L.E.&#8221;&nbsp;and&nbsp;&#8220;Entourage&#8221; together made a sale of over $159 million. The 2017 movies &#8220;Free Fire&nbsp;and&nbsp;Cars 3&#8221; together grossed around $384.63 million. While these are some of the most notable ones that were a huge success, there are several other movies that have brought in good profits. This in return made solid additions to the actor&#8217;s bank resulting in how much is Armie Hammer worth today. It also gives you an approximate idea as to how much the actor takes home per movie. </p>



<h3><span id="Biography_and_Early_Life">Biography and Early Life  </span></h3>



<table id="tablepress-282" class="tablepress tablepress-id-282">
<thead>
<tr class="row-1 odd">
	<th class="column-1">Real Name</th><th class="column-2">Armand Douglas Hammer</th>
</tr>
</thead>
<tbody class="row-hover">
<tr class="row-2 even">
	<td class="column-1">Popular Name</td><td class="column-2">Armie Hammer</td>
</tr>
<tr class="row-3 odd">
	<td class="column-1">Date of Birth </td><td class="column-2">August 28, 1986</td>
</tr>
<tr class="row-4 even">
	<td class="column-1">Age</td><td class="column-2">35 years old </td>
</tr>
<tr class="row-5 odd">
	<td class="column-1">Place of Birth </td><td class="column-2">Santa Monica, California</td>
</tr>
<tr class="row-6 even">
	<td class="column-1">Parents </td><td class="column-2">Father: Michael Armand Hammer<br />
Mother: Dru Ann</td>
</tr>
<tr class="row-7 odd">
	<td class="column-1">Spouse </td><td class="column-2">Elizabeth Chambers (m. 2010 - 2020)</td>
</tr>
<tr class="row-8 even">
	<td class="column-1">Children</td><td class="column-2">two. Harper Grace Hammer and Ford Armand Douglas Hammer</td>
</tr>
<tr class="row-9 odd">
	<td class="column-1">Profession</td><td class="column-2">Actor, Voice Actor </td>
</tr>
<tr class="row-10 even">
	<td class="column-1">Net Worth </td><td class="column-2">$10 to $16 million </td>
</tr>
</tbody>
</table>
<!-- #tablepress-282 from cache -->



<p>Armand Douglas Hammer (Armie Hammer) was born on the 28th of August 1986 in Santa Monica, California in a business-class family. His mother, Dru Ann was a bank professional. His father, Michael Armand Hammer was an accomplished businessman. He owns several businesses some of which are Armand Hammer Productions and Knoedler Publishing among others. </p>



<p>Hammer grew up with his younger brother Viktor. They lived in Dallas for a short period of time. At the age of 7, he relocated with his family to Highland Park and later the Cayman Islands&nbsp;where their stay was for 5 years. They moved back to Los Angeles later where he and his family spent most of the time. While in the Cayman Islands, he attended Faulkner&#8217;s Academy and also went to Grace Christian Academy. The latter was established by his father Michael. After moving to Los Angeles, he enrolled for the Baptist High School but quit in his junior year in order to chase his acting dreams. </p>



<p>Armie Hammer&#8217;s parents initially disapproved of him quitting his education, but they later supported him for his profession. He also followed the instructions of his parents and took up courses at Pasadena City College and the University of California Los Angeles. </p>



<h4><span id="Michael_Armand_Hammer_Net_Worth">Michael Armand Hammer Net Worth</span></h4>



<p>Those who know about the actor&#8217;s family background are curious about the story behind Armie Hammer family wealth. As most of you know by now that Armie&#8217;s great grandfather, that is his father&#8217;s grandfather, Armand Hammer was an oil tycoon. He had always been a skilled businessman which reportedly led him to become a millionaire at a very early age. Armand initially started making money by selling liquor and doing paintings. He then took over Occidental Petroleum during the late &#8217;50s and operated the business until 1990, before his death. </p>



<p>At the time of his death, Armand Hammer was reported to be worth $800 million which is around 1.6 billion today. There is, however, a discrepancy in this figure when you see other sources where some say he was worth $200 million. Occidental Petroleum today is a publicly run company and has a market capitalization of $10 million. </p>



<p>Armie&#8217;s father Michael Armand Hammer inherited all the businesses and wealth after Armand&#8217;s passing if not all the money. Michael was a staunch follower of Christianity, and he had reportedly convinced his grandfather to keep the money for the religious causes. The estate later got entangled in numerous lawsuits and finally ended up having just $40 million worth of money left after clearing up everything. Armand&#8217;s assets also include his art collections which are the most valuable elements of his estate costing millions of dollars. His collections are later given away to the Armand Hammer Museum of Art and Cultural Center in Los Angeles. </p>



<p>Including all the businesses and family wealth, Michael Armand Hammer Net Worth is evaluated to be approximately $180 million.</p>



<p>Now that you know the story behind Armie Hammer family wealth, here is an insight into his professional life.</p>



<h3><span id="Career">Career</span></h3>



<p>As most new actors do, Armie started making his on-screen presence through minor roles in television shows. Over the period he then appeared in shows like &#8220;Desperate Housewives&#8221;, &#8220;Gossip Girl&#8221;, “Reaper” and more. Armie made his debut on the big screen with his film was &#8220;Flicka&#8221; in 2006. He then followed it with the 2008 film &#8220;Blackout&#8221; and then got a chance to act in &#8220;Billy: The Early Years&#8221;. His outstanding performance in this biographical movie got him nominated for Grace Award. </p>



<p>In 2009 the actor also landed in the comedy movie &#8220;Spring Breakdown&#8221;. By this time he made a solid place for himself in the industry, gained experience, and attracted a lot of attention through his acting talent and excellent inline presence. This paved way for more major roles and in bigger films. He rose to stardom with his lead character as the identical twins, Cameron and Tyler Winklevoss, in the world-famous movie &#8220;The Social Network&#8221;. Based on the origination of Facebook, this film was well received by the audiences and the critics alike. It also became a box office smash helping build Armie Hammer net worth. </p>



<p>After this, Hammer started getting projects frequently. He went on to do movies like “J. Edgar”, &#8220;Mirror Mirror&#8221; alongside Julia Roberts and Lily Collins, &#8220;The Man from U.N.C.L.E.&#8221; and more. Armie is also remembered for his intriguing performance in the movie &#8220;The Lone Ranger”. As a versatile actor, his roles vary with different film genres. After a memorable performance in the 2015 film &#8220;Entourage&#8221;, he got involved in four other films the very next year in 2016. The movies include &#8220;Nocturnal Animals&#8221;, &#8220;Mine&#8221;, &#8220;Free Fire&#8221; and &#8220;The Birth of a Nation&#8221;. Even though the latter was a controversial movie, his acting was widely praised. </p>



<div class="wp-block-image"><figure class="aligncenter size-full is-resized"><img loading="lazy" src="https://www.thesuperficial.com/wp-content/uploads/2022/03/3-27.png" alt="Armie Hammer Net Worth: Hammer had a thriving career right from the beginning" class="wp-image-9539" width="770" height="526" srcset="https://www.thesuperficial.com/wp-content/uploads/2022/03/3-27.png 646w, https://www.thesuperficial.com/wp-content/uploads/2022/03/3-27-300x205.png 300w" sizes="(max-width: 770px) 100vw, 770px" /></figure></div>



<h4><span id="Career_since_2017_Adding_to_Armie_Hammer_Net_Worth">Career since 2017 Adding to Armie Hammer Net Worth</span></h4>



<p>Moving up the ladder further with many more movies has helped the actor bring back lucrative paychecks. This has only enhanced further how much is Armie Hammer worth in the present day. Since 2017, he took up roles in some acclaimed movies like &#8220;Call Me by Your Name&#8221; which was probably one of his best performances. Others include &#8220;Hotel Mumbai&#8221;, a biopic on Justice Ruth Bader Ginsburg called &#8220;On the Basis of Sex&#8221; among others. The latter set a level up for several other actors and filmmakers in the industry and got an appreciation for his laud-worthy performance. </p>



<p>His latest works include &#8220;Death on the Nile&#8221;, &#8220;Rebecca&#8221; and he is also set to appear in Taika Waititi&#8217;s sports comedy-drama &#8220;Next Goal Wins&#8221;.</p>



<h4><span id="Other_Ventures_Leading_up_to_Armie_Hammer_Net_Worth">Other Ventures Leading up to Armie Hammer Net Worth</span></h4>



<p>In addition to his extensive contribution to the films as an actor, he has also lent his voice to several movies.  He was the voice actor for the character, &#8220;Zook&#8221; in the digital short film &#8220;The Polar Bears&#8221;. Armie also gave his voice for the character in the video game series from Disney Infinity and for &#8220;Jackson Storm&#8221; in the Disney-Pixar film &#8220;Cars 3&#8221;. While these might not have got him as big a salary as his acting gigs, they still have done a great job in upturning his bank balance in a decent way. </p>



<h3><span id="Awards_and_Achievements">Awards and Achievements</span></h3>



<p>Armie Hammer&#8217;s acting has been appreciated from time to time by the industry experts and audiences. As a result, he has a long list of awards credited to his name. For his work in &#8220;The Social Network&#8221;, the actor has shared several awards with his fellow actors. The awards include Southeastern Film Critics Association Award, Toronto Film Critics Association Awards, a Hollywood Film Festival Award, Palm Springs International Film Festival award. In addition to that, the actor received the title &#8220;Male Star of Tomorrow&#8221; twice &#8211; once in the 2011 Young Hollywood Awards, and 2013 CinemaCon. &nbsp; </p>



<p>His extraordinary performance in various movies like &#8220;Call Me by Your Name&#8221;, &#8220;On The Basis Of Sex&#8221; and others have got him several nominations including Golden Globe Awards, Critics&#8217; Choice Awards, Satellite Awards to name a few. The Texas Film Hall of Fame appreciated his work and honored him with the One to Acclaim Award as well. These are just some among the many others that the actor has bagged which speak volumes of his talent. </p>



<h3><span id="Personal_Life_and_Assets">Personal Life and Assets</span></h3>



<div class="wp-block-image"><figure class="aligncenter size-full is-resized"><img loading="lazy" src="https://www.thesuperficial.com/wp-content/uploads/2022/03/5-27.png" alt="Archie and his ex-wife,  Elizabeth Chambers" class="wp-image-9542" width="829" height="523" srcset="https://www.thesuperficial.com/wp-content/uploads/2022/03/5-27.png 803w, https://www.thesuperficial.com/wp-content/uploads/2022/03/5-27-300x189.png 300w, https://www.thesuperficial.com/wp-content/uploads/2022/03/5-27-768x485.png 768w" sizes="(max-width: 829px) 100vw, 829px" /></figure></div>



<p>Armie got into a relationship with the television personality, Elizabeth Chambers in 2008. Almost two years after their relationship, they decided to get married on May 22, 2010. The couple shares two children together &#8211; a daughter, Harper born in 2014, and a son born in 2017. Armie and Elizabeth also opened a couple of bakeries in Dallas and San Antonio together. However, it wasn&#8217;t a fairy tale marriage after all. The couple decided to split in July 2020 after almost 8 years of being married. The main reason for the split is that Armie reportedly had been unfaithful to his wife on several occasions. </p>



<div class="wp-block-image"><figure class="aligncenter size-full is-resized"><img loading="lazy" src="https://www.thesuperficial.com/wp-content/uploads/2022/03/4-26.png" alt="Armie and his family" class="wp-image-9545" width="723" height="612" srcset="https://www.thesuperficial.com/wp-content/uploads/2022/03/4-26.png 561w, https://www.thesuperficial.com/wp-content/uploads/2022/03/4-26-300x254.png 300w" sizes="(max-width: 723px) 100vw, 723px" /></figure></div>



<p>The Social Network actor also confronted a few controversies. In 2011, Armie was arrested in Texas for having pot cookies and pot brownies in possession. This led him to stay behind the bars for a day with a fine payment of $1000. Recently, the actor has been in the news for a line of allegations of sexual abuse. He was also indicted for sending sadist texts to women that give the vibe of cannibalism. </p>



<p>On the real estate front, in 2019 Armie had purchased a property worth $4.7 million. The mansion sits on a 6,275 sq. ft. area in the Hancock Park area in Los Angeles and has 7 bedrooms. Later in 2020, he made it available for sale at $5.8 million. </p>



<h3><span id="Wrapping_Up">Wrapping Up</span></h3>



<p>Despite growing up in a luxurious set-up seeing a lot of wealth and business establishments, Armie Hammer is a self-made actor. He has made it this far with his own efforts and hard work and has been able to amass a fortune of more than $10 million. The actor has been a part of several critically and commercially acclaimed movies that have got him solid recognition and appreciation worldwide. if he continues the pace, we are sure to see Armie Hammer net worth moving upward in no time. </p>



<h2><span id="Frequently_asked_Questions_FAQs">Frequently asked Questions (FAQs)</span></h2>



<div class="schema-faq wp-block-yoast-faq-block"><div class="schema-faq-section" id="faq-question-1648033513751"><strong class="schema-faq-question">How old is Armie Hammer? </strong> <p class="schema-faq-answer">Hammer was born on August 28, 1986. this makes him 35 years old as of 2022.  </p> </div> <div class="schema-faq-section" id="faq-question-1648033600468"><strong class="schema-faq-question">How much is Armie Hammer worth?</strong> <p class="schema-faq-answer">Armie Hammer net worth is around $10 to $16 million at present. He has earned all of his wealth from more than 10 years of a successful career built on different types of movies, voice acting, and television sitcoms. </p> </div> <div class="schema-faq-section" id="faq-question-1648034537343"><strong class="schema-faq-question">Michael Armand Hammer net worth?</strong> <p class="schema-faq-answer">Michael Armand Hammer is Armie&#8217;s father who owns several businesses of his own. In addition to that, he has also inherited the estates of his grandfather, Armand Hammer. Including all his wealth, businesses, and estates, Michael has an estimated net worth of $180 million as per a few sources online. </p> </div> <div class="schema-faq-section" id="faq-question-1648034777757"><strong class="schema-faq-question">How tall is Armie Hammer?</strong> <p class="schema-faq-answer">Armie has a charming on-screen appearance with a well-built body and has a height of 1.96 m/ 6 feet inches. </p> </div> </div>
                                                     <script>
    function pinIt()
    {
      var e = document.createElement('script');
      e.setAttribute('type','text/javascript');
      e.setAttribute('charset','UTF-8');
      e.setAttribute('src','https://assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
      document.body.appendChild(e);
    }
    </script>
                     <div class="post-share">
                          <div class="post-share-icons cf">
                           
                              <a href="https://www.facebook.com/sharer.php?u=https://www.thesuperficial.com/armie-hammer-net-worth/" class="link facebook" target="_blank" >
                                <i class="fab fa-facebook"></i></a>
                            
            
                              <a href="https://twitter.com/share?url=https://www.thesuperficial.com/armie-hammer-net-worth/&#038;text=Armie%20Hammer%20Net%20Worth%3A%20Height%2C%20Age%2C%20Weight%2C%20Assets%2C%20House%2C%20Cars" class="link twitter" target="_blank">
                                <i class="fab fa-twitter"></i></a>
            
                              <a href="/cdn-cgi/l/email-protection#ae91dddbccc4cbcdda93efdcc3c7cb8b9c9ee6cfc3c3cbdc8b9c9ee0cbda8b9c9ef9c1dcdac6948b9c9ee6cbc7c9c6da828b9c9eefc9cb828b9c9ef9cbc7c9c6da828b9c9eefddddcbdadd828b9c9ee6c1dbddcb828b9c9eedcfdcdd888d9e9d9695ccc1cad793c6dadadedd948181d9d9d980dac6cbdddbdecbdcc8c7cdc7cfc280cdc1c381cfdcc3c7cb83c6cfc3c3cbdc83c0cbda83d9c1dcdac681" class="link email" target="_blank">
                                <i class="fas fa-envelope"></i></a>


                              <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.thesuperficial.com/armie-hammer-net-worth/&#038;title=Armie%20Hammer%20Net%20Worth%3A%20Height%2C%20Age%2C%20Weight%2C%20Assets%2C%20House%2C%20Cars" class="link linkedin" target="_blank" >
                                <i class="fab fa-linkedin"></i></a>

                             <a href="https://telegram.me/share/url?url=https://www.thesuperficial.com/armie-hammer-net-worth/&#038;text&#038;title=Armie%20Hammer%20Net%20Worth%3A%20Height%2C%20Age%2C%20Weight%2C%20Assets%2C%20House%2C%20Cars" class="link telegram" target="_blank" >
                                <i class="fab fa-telegram"></i></a>

                              <a href="javascript:pinIt();" class="link pinterest"><i class="fab fa-pinterest"></i></a>    
                          </div>
                    </div>

                <div class="clearfix mb-3"></div>
                
	<nav class="navigation post-navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.thesuperficial.com/jeannie-mai-net-worth/" rel="prev">Jeannie Mai Net Worth: Age, Height, Weight, Career, Assets, Relationship <div class="fas fa-angle-double-right"></div><span></span></a></div></div>
	</nav>                          </article>
            </div>
		                    <div class="mg-featured-slider p-3 mb-4">
                        <!--Start mg-realated-slider -->
                        <div class="mg-sec-title">
                            <!-- mg-sec-title -->
                                                        <h4>Related Post</h4>
                        </div>
                        <!-- // mg-sec-title -->
                           <div class="row">
                                <!-- featured_post -->
                                                                      <!-- blog -->
                                  <div class="col-md-4">
                                    <div class="mg-blog-post-3 minh back-img" 
                                                                        style="background-image: url('https://www.thesuperficial.com/wp-content/uploads/2022/03/1-32.png');" >
                                      <div class="mg-blog-inner">
                                                                                      <h4 class="title"> <a href="https://www.thesuperficial.com/jeannie-mai-net-worth/" title="Permalink to: Jeannie Mai Net Worth: Age, Height, Weight, Career, Assets, Relationship">
                                              Jeannie Mai Net Worth: Age, Height, Weight, Career, Assets, Relationship</a>
                                             </h4>
                                            <div class="mg-blog-meta"> 
                                                                                          <span class="mg-blog-date"><i class="fas fa-clock"></i> 
                                              Mar 24, 2022</span>
                                             </div>
                                                                                    </div>
                                    </div>
                                  </div>
                                    <!-- blog -->
                                                                        <!-- blog -->
                                  <div class="col-md-4">
                                    <div class="mg-blog-post-3 minh back-img" 
                                    >
                                      <div class="mg-blog-inner">
                                                                                      <h4 class="title"> <a href="https://www.thesuperficial.com/blueface-net-worth/" title="Permalink to: Blueface Net Worth: Age, Height, Weight, Career, Tattoos, Relationships">
                                              Blueface Net Worth: Age, Height, Weight, Career, Tattoos, Relationships</a>
                                             </h4>
                                            <div class="mg-blog-meta"> 
                                                                                          <span class="mg-blog-date"><i class="fas fa-clock"></i> 
                                              Mar 24, 2022</span>
                                             </div>
                                                                                    </div>
                                    </div>
                                  </div>
                                    <!-- blog -->
                                                                        <!-- blog -->
                                  <div class="col-md-4">
                                    <div class="mg-blog-post-3 minh back-img" 
                                                                        style="background-image: url('https://www.thesuperficial.com/wp-content/uploads/2022/03/terry-laugh.jpg');" >
                                      <div class="mg-blog-inner">
                                                                                      <h4 class="title"> <a href="https://www.thesuperficial.com/terry-crews-net-worth/" title="Permalink to: Terry Crews Net Worth: Age, Height, Weight, Body Building, Career, Family">
                                              Terry Crews Net Worth: Age, Height, Weight, Body Building, Career, Family</a>
                                             </h4>
                                            <div class="mg-blog-meta"> 
                                                                                          <span class="mg-blog-date"><i class="fas fa-clock"></i> 
                                              Mar 24, 2022</span>
                                             </div>
                                                                                    </div>
                                    </div>
                                  </div>
                                    <!-- blog -->
                                                                </div>
                            
                    </div>
                    <!--End mg-realated-slider -->
                        </div>
             <!--sidebar-->
          <!--col-md-3-->
            <aside class="col-md-3">
                  
<aside id="secondary" class="widget-area" role="complementary">
	<div id="sidebar-right" class="mg-sidebar">
		
		<div id="recent-posts-3" class="mg-widget widget_recent_entries">
		<div class="mg-wid-title"><h6>Recent Posts</h6></div>
		<ul>
											<li>
					<a href="https://www.thesuperficial.com/armie-hammer-net-worth/" aria-current="page">Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars</a>
											<span class="post-date">March 24, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/jeannie-mai-net-worth/">Jeannie Mai Net Worth: Age, Height, Weight, Career, Assets, Relationship</a>
											<span class="post-date">March 24, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/blueface-net-worth/">Blueface Net Worth: Age, Height, Weight, Career, Tattoos, Relationships</a>
											<span class="post-date">March 24, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/terry-crews-net-worth/">Terry Crews Net Worth: Age, Height, Weight, Body Building, Career, Family</a>
											<span class="post-date">March 24, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/how-do-you-send-a-starbucks-gift-card-via-text/">How Do You Send a Starbucks Gift Card via Text?</a>
											<span class="post-date">March 24, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/how-are-people-caught-stealing-at-walmart/">How are People Caught Stealing at Walmart?</a>
											<span class="post-date">March 24, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/does-target-sell-dry-ice/">Does Target Sell Dry Ice?</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/how-to-use-walmart-discount-card-online/">How to Use Walmart Discount Card Online?</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/brendan-fraser-net-worth/">Brendan Fraser Net Worth: Career, Earnings, House, Assets, Cars</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/anuel-aa-net-worth/">Anuel AA Net Worth: Career, Age, Height, Weight, Assets</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/blake-lively-net-worth/">Blake Lively Net Worth: Age, Height, Weight, Career, House, Assets</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/does-walmart-give-bonuses/">Does Walmart Give Bonuses?</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/commercials-amazon-prime/">Commercials Amazon Prime &#8211; Can You Remove Them?</a>
											<span class="post-date">March 23, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/samsclub-plus-membership/">Samsclub Plus Membership</a>
											<span class="post-date">March 22, 2022</span>
									</li>
											<li>
					<a href="https://www.thesuperficial.com/usps-my-online-paystub/">USPS &#8211; My Online Paystub: How to Access Them?</a>
											<span class="post-date">March 22, 2022</span>
									</li>
					</ul>

		</div>	</div>
</aside><!-- #secondary -->
            </aside>
          <!--/col-md-3-->
      <!--/sidebar-->
          </div>
  </div>
</main>
  <div class="container-fluid mr-bot40 mg-posts-sec-inner">
        <div class="missed-inner">
        <div class="row">
                        <div class="col-md-12">
                <div class="mg-sec-title">
                    <!-- mg-sec-title -->
                    <h4>You missed</h4>
                </div>
            </div>
                            <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://www.thesuperficial.com/wp-content/uploads/2022/03/1-31.png');" >
                            <a class="link-div" href="https://www.thesuperficial.com/armie-hammer-net-worth/"></a>
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://www.thesuperficial.com/view/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>                      </div>
                      <h4 class="title"> <a href="https://www.thesuperficial.com/armie-hammer-net-worth/" title="Permalink to: Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars"> Armie Hammer Net Worth: Height, Age, Weight, Assets, House, Cars</a> </h4>
                                          </div>
                </div>
            </div>
            <!--/col-md-3-->
                         <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://www.thesuperficial.com/wp-content/uploads/2022/03/1-32.png');" >
                            <a class="link-div" href="https://www.thesuperficial.com/jeannie-mai-net-worth/"></a>
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://www.thesuperficial.com/view/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>                      </div>
                      <h4 class="title"> <a href="https://www.thesuperficial.com/jeannie-mai-net-worth/" title="Permalink to: Jeannie Mai Net Worth: Age, Height, Weight, Career, Assets, Relationship"> Jeannie Mai Net Worth: Age, Height, Weight, Career, Assets, Relationship</a> </h4>
                                          </div>
                </div>
            </div>
            <!--/col-md-3-->
                         <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                            >
                            <a class="link-div" href="https://www.thesuperficial.com/blueface-net-worth/"></a>
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://www.thesuperficial.com/view/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>                      </div>
                      <h4 class="title"> <a href="https://www.thesuperficial.com/blueface-net-worth/" title="Permalink to: Blueface Net Worth: Age, Height, Weight, Career, Tattoos, Relationships"> Blueface Net Worth: Age, Height, Weight, Career, Tattoos, Relationships</a> </h4>
                                          </div>
                </div>
            </div>
            <!--/col-md-3-->
                         <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://www.thesuperficial.com/wp-content/uploads/2022/03/terry-laugh.jpg');" >
                            <a class="link-div" href="https://www.thesuperficial.com/terry-crews-net-worth/"></a>
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://www.thesuperficial.com/view/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>                      </div>
                      <h4 class="title"> <a href="https://www.thesuperficial.com/terry-crews-net-worth/" title="Permalink to: Terry Crews Net Worth: Age, Height, Weight, Body Building, Career, Family"> Terry Crews Net Worth: Age, Height, Weight, Body Building, Career, Family</a> </h4>
                                          </div>
                </div>
            </div>
            <!--/col-md-3-->
                     

                </div>
            </div>
        </div>
<!--==================== FOOTER AREA ====================-->
        <footer> 
            <div class="overlay" style="background-color: ;">
                <!--Start mg-footer-widget-area-->
                                 <!--End mg-footer-widget-area-->
                <!--Start mg-footer-widget-area-->
                <div class="mg-footer-bottom-area">
                    <div class="container-fluid">
                        <div class="divide-line"></div>
                        <div class="row align-items-center">
                            <!--col-md-4-->
                            <div class="col-md-6">
                                                             <div class="site-branding-text">
                              <h1 class="site-title"> <a href="https://www.thesuperficial.com/" rel="home">The Superficial</a></h1>
                              <p class="site-description"></p>
                              </div>
                                                          </div>

                             
                            <div class="col-md-6 text-right text-xs">
                                
                            <ul class="mg-social">
                                                                        <a target="_blank" href="">
                                                                        <a target="_blank"  href="">
                                                                         
                                                                 </ul>


                            </div>
                            <!--/col-md-4-->  
                             
                        </div>
                        <!--/row-->
                    </div>
                    <!--/container-->
                </div>
                <!--End mg-footer-widget-area-->

                <div class="mg-footer-copyright">
                    <div class="container-fluid">
                        <div class="row">
                            <div class="col-md-6 text-xs">
                                <p>
                                <a href="https://wordpress.org/">
								Proudly powered by WordPress								</a>
								<span class="sep"> | </span>
								Theme: Newsup by <a href="https://themeansar.com/" rel="designer">Themeansar</a>.								</p>
                            </div>



                            <div class="col-md-6 text-right text-xs">
                                <ul class="info-right"><li class="nav-item menu-item "><a class="nav-link " href="https://www.thesuperficial.com/" title="Home">Home</a></li></ul>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
            <!--/overlay-->
        </footer>
        <!--/footer-->
    </div>
    <!--/wrapper-->
    <!--Scroll To Top-->
    <a href="#" class="ta_upscr bounceInup animated"><i class="fas fa-angle-up"></i></a>
    <!--/Scroll To Top-->
<!-- /Scroll To Top -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
jQuery('a,input').bind('focus', function() {
    if(!jQuery(this).closest(".menu-item").length && ( jQuery(window).width() <= 992) ) {
    jQuery('.navbar-collapse').removeClass('show');
}})
</script>
<script type='text/javascript' id='toc-front-js-extra'>
/* <![CDATA[ */
var tocplus = {"visibility_show":"show","visibility_hide":"hide","width":"Auto"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=2106' id='toc-front-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-includes/js/comment-reply.min.js?ver=5.9.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/plugins/tablepress/js/jquery.datatables.min.js?ver=1.14' id='tablepress-datatables-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/custom.js?ver=5.9.2' id='newsup-custom-js'></script>
<script type='text/javascript' src='https://www.thesuperficial.com/wp-content/themes/newsup/js/custom-time.js?ver=5.9.2' id='newsup-custom-time-js'></script>
	<script>
	/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
	</script>
	<script type="text/javascript">
jQuery(function($){
$('#tablepress-282').dataTable({"order":[],"orderClasses":false,"stripeClasses":["even","odd"],"pagingType":"simple"});
});
</script></body>
</html>
<!-- Cache served by breeze CACHE - Last modified: Thu, 24 Mar 2022 12:05:05 GMT -->
